v Web development

Upgrade z Apache 2.2 na 2.4

Už u několika projektů jsem se setkal s problémem při upgradu webserveru Apache z dlouho používané verze 2.2 na 2.4. Řešení je jednoduché.

Jak to vyřešit

Ve verzi 2.2 se pro definici přístupu v jednotlivých virtualhostech používalo (pro povolení všech přístupů):

Order allow,deny
Allow from all

Verze 2.4 přichází s novým modulem mod_authz_host, kde je stejná konfigurace následující:

Require all granted

Kde se s problémem můžete setkat

  • upgrade Mac OS X na Yosemite (Server version: Apache/2.4.9 (Unix))
  • upgrade Apache na hostingu

Pokud vám projekt pořád nefunguje, ověřte jestli nepoužíváte nějakou další změněnou konfiguraci.

Líbilo se? Tak to sdílej, dík:)Share on FacebookTweet about this on TwitterEmail this to someone

Komentáře

Komentář

  • Podobný obsah podle štítku